<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lato:300,400,900,900italic,300italic,400italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Southern Film Festival begins in LaGrange today - Valley Times-News | Valley Times-News</title>

                <meta name="viewport" content="width=device-width, initial-scale=1">

				<link rel="stylesheet" href="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.min.css?1629743770" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1629743770" />
				<link rel="stylesheet" href="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/css/normalize.css?1629743770" />
				<link rel="stylesheet" href="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/css/base.css?1629743770" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/style.css?1629902791" />

        <script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/modernizr-2.6.2.min.js?1629743770"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.valleytimes-news.com/wp-content/themes/2016-valley-mobile-child/media/img/brand/favicon-valleytimes-news.png">
				<link rel="apple-touch-icon" href="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/images/brand/apple-touch-icon.png" />

				
																<meta name='robots' content='max-image-preview:large' />

	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Southern Film Festival begins in LaGrange today - Valley Times-News" />
	<meta property="og:description" content="The Lanett Film Festival, an annual tradition for filmmakers, has evolved into something larger and has moved to LaGrange. On Friday and Saturday, the Southern Film Festival will take place at LaFayette Society for Performing Arts in downtown LaGrange on Friday, Aug. 27 and Saturday, Aug. 28, according to a Southern Film Festival press release. [&hellip;]" />
	<meta property="og:url" content="https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/" />
	<meta property="og:site_name" content="Valley Times-News" />
	<meta property="article:published_time" content="2021-08-27T11:39:23+00:00" />
	<meta property="og:image" content="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="450" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Cole Trahan">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="5 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.valleytimes-news.com/#website","url":"https://www.valleytimes-news.com/","name":"Valley Times-News","description":"Serving Lanett and Valley, Alabama and West Point, Georgia","potentialAction":[{"@type":"SearchAction","target":"https://www.valleytimes-news.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/#primaryimage","inLanguage":"en-US","url":"https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg","width":800,"height":450},{"@type":"WebPage","@id":"https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/#webpage","url":"https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/","name":"Southern Film Festival begins in LaGrange today - Valley Times-News","isPartOf":{"@id":"https://www.valleytimes-news.com/#website"},"primaryImageOfPage":{"@id":"https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/#primaryimage"},"datePublished":"2021-08-27T11:39:23+00:00","dateModified":"2021-08-27T11:39:23+00:00","author":{"@id":"https://www.valleytimes-news.com/#/schema/person/4554e4597c8f8f6567c2ef98906f3d25"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/"]}]},{"@type":"Person","@id":"https://www.valleytimes-news.com/#/schema/person/4554e4597c8f8f6567c2ef98906f3d25","name":"Cole Trahan","image":{"@type":"ImageObject","@id":"https://www.valleytimes-news.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ab96b1c61fbec62b840e382f19245ec7?s=96&d=mm&r=g","caption":"Cole Trahan"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.valleytimes-news.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="Valley Times-News &raquo; Southern Film Festival begins in LaGrange today Comments Feed" href="https://m.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/m.valleytimes-news.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://m.valleytimes-news.com/_static/??-eJyNjFEKwjAQRC9kula04od4lk2y6NpNUrIpmtsbBKUign8z82YGbpPh6GT2pOBUwaNe2KWoXeDYtWQFy8pVoTQ+2nR/i+/W84i1gJXkRiNsM+YKWqrQz99AnpGEAsXyYSbBStkIndHV/+aNLf1rdArHftgc+u1uWO8fkbxdGw==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.valleytimes-news.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.valleytimes-news.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.8' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://m.valleytimes-news.com/wp-includes/css/admin-bar.min.css?m=1629145607g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.valleytimes-news.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.valleytimes-news.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.valleytimes-news.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='widgetopts-styles-css'  href='https://www.valleytimes-news.com/wp-content/plugins/widget-options/assets/css/widget-options.css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/style.css?ver=5.8' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.valleytimes-news.com/wp-content/themes/2016-valley-mobile-child/style.css?ver=1629743771' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.valleytimes-news.com/wp-content/mu-plugins/jetpack-10.0/_inc/social-logos/social-logos.min.css?ver=10.0' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.valleytimes-news.com/wp-content/mu-plugins/jetpack-10.0/css/jetpack.css?ver=10.0' media='all' />
<script type='text/javascript' src='https://m.valleytimes-news.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZkaWhiamZgXkWAK94IiE='></script>
<link rel="https://api.w.org/" href="https://m.valleytimes-news.com/wp-json/" /><link rel="alternate" type="application/json" href="https://m.valleytimes-news.com/wp-json/wp/v2/posts/29242" /><link rel='shortlink' href='https://m.valleytimes-news.com/?p=29242' />
<link rel="alternate" type="application/json+oembed" href="https://m.valleytimes-news.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.valleytimes-news.com%2F2021%2F08%2Fsouthern-film-festival-begins-in-lagrange-today%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://m.valleytimes-news.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.valleytimes-news.com%2F2021%2F08%2Fsouthern-film-festival-begins-in-lagrange-today%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-114791706-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-114791706-1');
</script>
<link rel="icon" href="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2020/04/cropped-WPlogo.png?w=32" sizes="32x32" />
<link rel="icon" href="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2020/04/cropped-WPlogo.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2020/04/cropped-WPlogo.png?w=180" />
<meta name="msapplication-TileImage" content="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2020/04/cropped-WPlogo.png?w=270" />
<!-- Your Google Analytics Plugin is missing the tracking ID -->
								<script type="text/javascript">
          var $ = jQuery;
          var adm_dmm_id = '5f60d5030cb01b3891d025aa';
          var adm_dam_id = '5f60d53e0cb01b3891d025ae';
          var adm_dpm_id = '5f60d51b0cb01b3891d025ac';
          var loggedin = false;
          window.admiral = window.admiral || function() {(admiral.q = admiral.q || []).push(arguments)};

          function setCookie() {
              window.admiral('after','measure.detected',function(user) {
                  var d = new Date();
                  d.setTime(d.getTime() + (7*24*60*60*1000));
                  var n = d.toUTCString();
                  if (user.subscribed) {
                      document.cookie = "bni_admiral_loggedin=1; expires=" + n + "; path=/";
                      loggedin = true;
                      return;
                  }
                  document.cookie = "bni_admiral_loggedin=0; expires=" + n + "; path=/";
                  window.sessionStorage.setItem('cfS', '0');
              })
          }
          window.onload = setCookie();

          function readCookie(c) {
              var a = document.cookie.split(';');
              for (var i = 0; i < a.length; i++) {
                  var b = a[i].split('=');
                  var d = b[0].trim();
                  if (c === d) {
                      var e = b[1].trim();
                      if (e === "1") {
                          loggedin = true;
                      } else {
                          loggedin = false;
                      }
                  }
              }
              return true;
          }
          window.onload = readCookie('bni_admiral_loggedin');
          window.admiral('after', 'transact.subscribed', function() {
              var x = window.sessionStorage.getItem('cfS');
              if (x === "1") {
                  return;
              }
              window.sessionStorage.setItem('cfS', '1');
              location.reload();
          })

          $(window).load(function() { // These functions get called when everything has loaded
            if (!loggedin) {
              $("#slidebarList").prepend('<li><a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.login&quot;,{offerID:&quot;' + adm_dmm_id + ',' + adm_dpm_id + ',' + adm_dam_id + '&quot;});">Log In</a></li>');
            } else {
              $("#slidebarList").prepend('<li><a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.manage&quot;);">Manage Account</a></li>');
            }
            //console.log('%c TESTING ADMIRAL V 2.1', 'background: #222; color: #bada55');
          });

          $( document ).ready(function() {
            // Digital Monthly Membership
            $('#adm_dmm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dmm_id})
            });
            // Digital Annual Membership
            $('#adm_dam').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dam_id})
            });
            // Digital and Print Membership
            $('#adm_dpm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dpm_id})
            });
          });
				</script>


				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {
    			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/VLL-m-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/VLL-m-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
    

			googletag.defineSlot('/1613683/VLL-m-320x50-1', [320, 50], 'div-gpt-ad-mobile-leader').addService(googletag.pubads());
			BIGBLOCK_AD_ONE = googletag.defineSlot('/1613683/VLL-m-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			BIGBLOCK_AD_TWO = googletag.defineSlot('/1613683/VLL-m-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			BIGBLOCK_AD_THREE = googletag.defineSlot('/1613683/VLL-m-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-300x250-6', [300, 250], 'div-gpt-ad-bigblock-6').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());
  if (!loggedin) {
			googletag.defineOutOfPageSlot('/1613683/VLL-m-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
			googletag.defineSlot('/1613683/VLL-m-320x50-sticky', [[320, 50], [1, 1]], 'div-gpt-ad-mobile-sticky').addService(googletag.pubads());
  }

                  googletag.pubads().setTargeting("catname", [ "news", "news-main",  ]);
          
          googletag.pubads().setTargeting("pageurl", "/2021/08/southern-film-festival-begins-i");
    
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });

		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
		googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/VLL-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/VLL-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/VLL-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/VLL-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/VLL-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/VLL-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/VLL-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/VLL-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/VLL-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/VLL-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/VLL-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/VLL-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/VLL-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/VLL-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/VLL-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/VLL-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/VLL-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/VLL-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/VLL-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/VLL-320x50-1',
          sizes: [[320, 50], [1, 1]]
      }
     ],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-leader', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-4', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-5', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-6', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-sticky', mt_in_view, mt_on_page, [['refresh', 'true']]],
      ]);
  </script>
        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/ieqAI8pckeKu2Ry07h29RBlsJsMVpsyUQZN7MeA-uiXim7i4Vy3a0UsF8C8ogAHeiByrF2w9ECml0k",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>

                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        
    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://m.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_ycbnmart6etzkdhtakbxwxdbai'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div class="undertone">

				<div class="mobile-nav sb-slide">
									<div class="sb-toggle-left navbar-left">
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
					</div><!-- /.sb-control-left -->
					<a href="https://m.valleytimes-news.com">
						<img class="logo" src="https://www.valleytimes-news.com/wp-content/themes/2016-valley-mobile-child/media/img/brand/logo-white-valleytimes-news.png" alt="Valley Times-News" />
					</a>
					<div class="search">
						<a href="#" class="expand">expand</a>
						<form method="get" class="searchForm" action="https://m.valleytimes-news.com/site-search">
							<input type="submit" class="searchButton" value="Go" />
							<input type="text" name="q" class="searchQuery" value="Search Valley Times-News..." onfocus="if(this.value=='Search Valley Times-News...'){this.value='';}" onblur="if(this.value==''){this.value='Search Valley Times-News...';}" />
						</form>
					</div>
				</div>

				<div id="sb-site">
					<!-- Add your site or application content here -->
					<div class="upper_ad">
						<div class="wrapper">
							<div class="ad">
								<div class="ad720x90">Ad Spot</div>
							</div>
						</div>
					</div>
					<div class="sup_nav">
						<div class="wrapper">
							<ul id="supNav">
	<li class="contests"><a href="https://m.valleytimes-news.com/contests/">Contests</a></li>
	<li class="subscribe"><a href="https://m.valleytimes-news.com/subscriptions/">Subscribe</a></li>
  <li><a href="">Services</a>
		<ul class="sub-nav">
      <li class="about"><a href="https://m.valleytimes-news.com/services/about-us/">About Us</a></li>
      <li><a href="https://m.valleytimes-news.com/services/policies/" title="" rel="bookmark">Terms of Use</a></li>
    </ul>
  </li>
  	<li class="submit">
		<a href="https://m.valleytimes-news.com/submit/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://m.valleytimes-news.com/submit/submit-photo/">Submit a photo</a></li>		
			<li><a href="https://m.valleytimes-news.com/submit/news-tip/">Submit a news tip</a></li>
			<li><a href="https://m.valleytimes-news.com/submit/letter-to-editor">Submit a Letter to the Editor</a></li>
			<li><a href="https://m.valleytimes-news.com/submit/engagement-announcement/">Submit an Engagement announcement</a></li>
			<li><a href="https://m.valleytimes-news.com/submit/wedding-announcement/">Submit a Wedding announcement</a></li>
			<li><a href="https://m.valleytimes-news.com/submit/anniversary-announcement/">Submit an Anniversary announcement</a></li>
		</ul>
	</li>
	<li class="classifieds"><a href="https://marketplace.valleytimes-news.com/AdHunter/valleytimesnews/">Classifieds</a></li>
	<li class="public-notices"><a href="https://marketplace.valleytimes-news.com/AdHunter/valleytimesnews/Home/Search?majorClass=2600">Public Notices</a></li>
</ul>							<p class="date">
								August 29, 2021							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div class="wrapper">
						<header>
							<nav id="navbar">
								<ul id="mainNav">
	<li class="home "><a href="https://m.valleytimes-news.com">Home</a></li>
	<li class="news "><a href="https://m.valleytimes-news.com/category/news/">News</a></li>
	<li class="sports"><a href="https://m.valleytimes-news.com/category/sports/">Sports</a></li>
	<li class="opinion"><a href="https://m.valleytimes-news.com/category/opinion/">Opinion</a></li>
	<li class="obits"><a href="https://m.valleytimes-news.com/category/obituaries/">Obits</a></li>
	<li class="eedition"><a href="https://subscriptions.valleytimes-news.com/CircStore/Account/Login?vendor=DirXion&prodId=VTN">E-Edition</a></li>
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content">
							<div id="notifications">
								






								


								
								
							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  </script>
</div>	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div></div>

	
							<div class="ad first">
								<!-- 320x50_mobile_leader -->
<div id='div-gpt-ad-mobile-leader'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-leader'); });
  </script>
</div>							</div>



							<div class="main_column">
								<div class="story">
									
									
                      <div class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://m.valleytimes-news.com/2021/08/estimated-1500-attend-concert-at-the-oaks-in-lafayette/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://m.valleytimes-news.com/2021/08/estimated-1500-attend-concert-at-the-oaks-in-lafayette/">
              <img src="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/concert-1FW.jpg?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://m.valleytimes-news.com/2021/08/estimated-1500-attend-concert-at-the-oaks-in-lafayette/">Estimated 1,500 attend concert at The Oaks in LaFayette</a> </h4>
          <a href="https://m.valleytimes-news.com/2021/08/estimated-1500-attend-concert-at-the-oaks-in-lafayette/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    <dl class='story_photo_item'><dt><img width="622" height="350" src="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg?w=622" class="attachment-story-photo size-story-photo wp-post-image" alt="" loading="lazy" srcset="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg 800w, https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg?resize=300,169 300w, https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg?resize=768,432 768w, https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/Southern-Film-Festival-Fowler-in-1938-PackardFW.jpg?resize=622,350 622w" sizes="(max-width: 622px) 100vw, 622px" /></dt><dd class='wp-caption-text'></dd></dl>

              </div>
    </div>
		
									<div id="leftRail" class="">
																			</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Southern Film Festival begins in LaGrange today</h2>

										<div class="byline">
											
											<a href="https://m.valleytimes-news.com/author/coletrahan/" rel="bookmark">
                        <img alt='' src='https://secure.gravatar.com/avatar/ab96b1c61fbec62b840e382f19245ec7?s=120&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ab96b1c61fbec62b840e382f19245ec7?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' loading='lazy'/>											</a>

											<p class="author">
												<strong>By <a href="https://m.valleytimes-news.com/author/coletrahan/" rel="bookmark">Cole Trahan</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:cole.trahan@lagrangenews.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 6:39 am Friday, August 27, 2021</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>                    </div>

										<div class="p402_premium">


										
										<div class="story_detail">
                      <div class="read_more_wrap">
                        
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>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</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=e70df43f977e0871402cfc4fc4318688&postHash=4de08144df53708fe03c7be0554640fe&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><p><span class="s1">The Lanett Film Festival, an annual tradition for filmmakers, has evolved into something larger and has moved to LaGrange. On Friday and Saturday, the Southern Film Festival will take place at LaFayette Society for Performing Arts in downtown LaGrange on Friday, Aug. 27 and Saturday, Aug. 28, according to a Southern Film Festival press release. </span></p>
<p><span class="s1">Twenty-eight films will be presented during the festival, including narrative shorts, documentaries, student films, and features. Many of the films were made by artists in Alabama and Southern Georgia, and one of them, “A President in Our Midst: Franklin Delano Roosevelt in Georgia,” has many LaGrange and Troup County connections, according to a press release by author and screenwriter Kaye Minchew.</span></p>
<p><span class="s1">“A President in our Midst” will be featured on Saturday, Aug. 28 at 7 p.m. The one-hour documentary describes President Franklin Delano Roosevelt’s special relationship with Georgia and the mutual benefits of that friendship between him and its inhabitants.</span></p>
<div id='mydfpad' class='ad300x ad'>
            <div id='div-gpt-ad-bigblock-1'>
              <script>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
              </script>
            </div>
          </div>
          <div id='cedato-unit'></div><p><span class="s1">Minchew and executive producer Dan White approached Georgia Public Broadcasting with a proposal to create their documentary.</span></p>
<p><span class="s1">“With the assurance of a broadcast platform, efforts began to secure the financing and technical resources necessary to complete the film,” the press release said. “A year later, Georgia Humanities agreed to be the official sponsor of the documentary and Georgia State University TV agreed to provide the technical expertise necessary to create the film.”</span></p>
<p><span class="s1">Filming began in September 2020. Locations featured in the film include LaGrange, Gainesville, Athens, Atlanta, Warm Springs, Thomaston, Barnesville and Harris, Meriwether and Upson Counties.</span></p>
<div id='mydfpad3' class='ad300x ad'>
                  <div id='div-gpt-ad-bigblock-2'>
                    <script>
                      googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
                    </script>
                  </div>
                  </div><p><span class="s1">The film uses drone photography, location shooting, archival photos, and historical film clips to give viewers a contemporary image of life during the period from 1921 to 1945. It was financed by privately raised public donations. Over 70 Georgians helped create the film. Among its performers are Carol Howington Cain (a LaGrange actress) in several roles, James Fowler as FDR, and Bill Murray as the narrator. An antique Packard convertible owned by Judy and Taylor Merrill of LaGrange is featured in the film.</span></p>
<p><span class="s1">“I’m so excited, both to have the film being shown here and to be part of the film festival,” Minchew said. “We certainly hope that people [will] enjoy the film, and it will be interesting to see what they learn new and what they think about it.”</span></p>
<p><span class="s1">Minchew said that while a lot of people know about FDR’s involvement in Georgia, the film contains many details that many people aren’t aware of. She is interested to see how people will react to different parts of the film.</span></p>
<div id='mydfpad4' class='ad'>
                  <div id='div-gpt-ad-instory-third'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                  </script>
                  </div>
                  </div><p><span class="s1">“West Georgia was so important to FDR’s life and his time in Georgia, so we’re excited to have this film about FDR in Georgia be playing here in LaGrange and Troup County,” she said.</span></p>
<p><span class="s1">Guests of the film festival will be able to meet directors, actors, and producers of the films.</span></p>
<p><span class="s1">“Panel discussions with more than a dozen artists will provide exciting and informative insights into issues in contemporary filmmaking, as well as providing opportunities for filmmakers to interact with audience members,” says the Southern Film Festival press release.</span></p>
<div id='mydfpad2' class='ad300x ad'>
          <div id='div-gpt-ad-bigblock-3'>
            <script>
              googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
            </script>
          </div>
          </div><p><span class="s1">There will be prominent featured guests at the festival. One will be Oscar-nominated producer Enrique “Rico” Diaz, who is known for his films “Dekalb Elementary,” “Perfect People,” and “Jeremy.” Kelley Lockman, an actor, director, and screenwriter who was born and raised in Georgia, has appeared in various TV shows and films, including Tyler Perry’s “A Fall from Grace.” Mike Hayhurst, an award-winning director and producer for film and theater, spent four years as an Associate at Ostar Enterprises (Rizzoli &amp; Isles, TNT; Beauty and the Beast, CW; Nothing to Hide, directed by Neil Patrick Harris at Signature Theater; various Broadway projects). </span></p>
<p><span class="s1">Also premiering at the festival will be “Brotherly Vows,” the second film made by LaGrange native Zeke Weldon and Theo M. Moore’s “Afrikan by Way of American: The Legacy and Future of Africatown in Alabama.”</span></p>
<p><span class="s1">“Our vision is to encourage filmmakers, both professional and novice, along the film-making process and catapult them into their full potential,” said the film festival’s founder, Eric Wright. </span></p>
<p><span class="s1">After working with Lafayette Theatre Academy director, Amy McDow, at Wright’s Lanett City Film Festival, Wright and McDow collaborated to increase educational opportunities for potential film artists. In addition to serving as hosts for the film festival, academy students will show their first student film there.</span></p>
<p><span class="s1">“Wright turned the studios and halls of LSPA into a film set and directed students on camera, also allowing them to assist with the technical side of filming,” says the Southern Film Festival press release. </span></p>
<p><span class="s1">“‘Exit’ was written by filmmaker Josh Tippey specifically for LTA and is a mockumentary that looks behind the scenes of a student-led theatrical production.”</span></p>
<p><span class="s1">McDow said she and Wright had worked together on the Lanett City Film Festival since its first year and that it ran for four. After the city of Lanett opted not to continue the festival in 2021, McDow and Wright set their sights on LaGrange. According to Lanett City Hall administrative secretary Sharon Brooks, a major reason the city decided not to continue the festival was COVID-19.</span></p>
<p><span class="s1">“We still had all of the connections with the filmmakers and artists that had been coming into this area, and we wanted to be able to continue this amazing opportunity for independent filmmakers,” McDow said. “And so, I worked at New Horizon, which was the main venue for the Lanett City Film Festival, and then, I also worked at LSPA. And my students in the academy had been hosting the film festival in Lanett for four years. So, we already had that connection, and it just felt organic. It just seemed like the most logical next step would be to expand the area of interest for the festival by broadening it out of a city and making it a region.”</span></p>
<p><span class="s1">McDow said she and others found LSPA to be an ideal place to host a film festival because it’s conveniently located in downtown LaGrange, where there are plenty of stores, restaurants and history.</span></p>
<p><span class="s1">Films entered into the festival can win multiple awards, which will be presented at 9 p.m. on Saturday. The “People’s Choice” award is voted on by the audience. Award categories include Best Feature Film, Best Short Film, Best Full-length Documentary, Best Documentary Short, Best Actor and Best Actress. </span></p>
<p><span class="s1">Those attending the festival Friday evening will have to access the LSPA Building from Lewis Street or Broome Street, as The LaGrange Cycling Classic will be using Bull Street for their event.</span></p>
<p><span class="s1">“Tickets are available by day or as a VIP full-weekend pass. Tickets for Friday viewings are $10 for adults and $8 for students, tickets for Saturday are $20 for adults and $15 for students. A full festival VIP ticket can be purchased for $35 for adults and $25 for students, which includes reserved seating in the LTC Black Box Theatre for the entire event and a welcome package. For more information, to purchase tickets, or to view trailers from the films, visit www.southernfilmfestival.com.</span></p>
<p><span class="s1">Anyone interested in the festival can view trailers of the films on the festival website, making it easier to determine which films to watch.</span></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-29242" class="share-twitter sd-button share-icon" href="https://m.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-29242" class="share-facebook sd-button share-icon" href="https://m.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-176206029-29242-612b8b306c2d2' data-src='https://widgets.wp.com/likes/#blog_id=176206029&amp;post_id=29242&amp;origin=m.valleytimes-news.com&amp;obj_id=176206029-29242-612b8b306c2d2' data-name='like-post-frame-176206029-29242-612b8b306c2d2' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
                                              


                      </div>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>
											</div>

	              
<div class="more_to_explore">
  <h4>More News</h4>

  
        <div class="story">
                    <a href="https://m.valleytimes-news.com/2018/09/valley-woman-charged-with-murder-indicted-for-corpse-abuse/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2018/09/police_car-622x415.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.valleytimes-news.com/2018/09/valley-woman-charged-with-murder-indicted-for-corpse-abuse/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="Valley woman charged with murder indicted for corpse abuse">Valley woman charged with murder indicted for corpse abuse</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://m.valleytimes-news.com/2021/08/our-view-fda-approval-should-mean-more-vaccinations/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="OUR VIEW: FDA approval should mean more vaccinations">OUR VIEW: FDA approval should mean more vaccinations</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://m.valleytimes-news.com/2021/08/remembering-a-time-when-negative-was-positive/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="Remembering a time when  negative was positive">Remembering a time when  negative was positive</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://m.valleytimes-news.com/2021/08/brooks-column-on-public-confession-of-sin/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="BROOKS COLUMN: On public confession of sin">BROOKS COLUMN: On public confession of sin</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <a href="https://m.valleytimes-news.com/2021/08/baker-lafayette-run-all-over-coosa-central/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" class="teasePhoto" rel="bookmark">
            <img width="400" height="220" src="https://m.valleytimes-news.com/wp-content/uploads/sites/47/2021/08/bakerFW.jpg?w=400&amp;h=220&amp;crop=1" class="attachment-category-medium size-category-medium wp-post-image" alt="" loading="lazy" />          </a>
                    <h3><a href="https://m.valleytimes-news.com/2021/08/baker-lafayette-run-all-over-coosa-central/?utm_source=site&utm_medium=mobile&utm_campaign=recirculation" rel="bookmark" title="Baker, LaFayette run all over Coosa Central">Baker, LaFayette run all over Coosa Central</a></h3>

          <div class="clearfix"></div>
        </div>

        
</div>
        <ul class="sidebar">
                    </ul>
	

                      <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134197"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
    

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



												

<div id="disqus_thread"></div>

<script>
    /**
    * RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
    * LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
    */
    /*
    */
    var disqus_config = function () {
      //this.page.url = 'https://m.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/';
      this.page.identifier = '29242 https://m.valleytimes-news.com/?p=29242';
      this.page.title = 'Southern Film Festival begins in LaGrange today - Valley Times-News';
    };
    (function() { // DON'T EDIT BELOW THIS LINE
    var d = document, s = d.createElement('script');

    s.src = '//valleytimes-news.disqus.com/embed.js';

    s.setAttribute('data-timestamp', +new Date());
    (d.head || d.body).appendChild(s);
    })();
</script>
  <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>



									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
      <div id='div-gpt-ad-bigblock-4'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-4'); });
  </script>
</div>		</div>
	</li>
	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Local News</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/baker-lafayette-run-all-over-coosa-central/" title="Permalink to Baker, LaFayette run all over Coosa Central" rel="bookmark">Baker, LaFayette run all over Coosa Central</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/valley-beats-lanett-in-another-classic-matchup-between-the-two-rivals/" title="Permalink to Valley beats Lanett in another classic matchup between the two rivals" rel="bookmark">Valley beats Lanett in another classic matchup between the two rivals</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/charter-foundation-still-going-strong/" title="Permalink to Charter Foundation still going strong" rel="bookmark">Charter Foundation still going strong</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/the-heritage-of-strength-woven-in/" title="Permalink to The heritage of Strength Woven In" rel="bookmark">The heritage of Strength Woven In</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/lifesouth-in-need-of-convalescent-plasma-to-host-blood-drives-in-lanett-and-valley/" title="Permalink to LifeSouth in need of convalescent plasma, to host blood drives in Lanett and Valley" rel="bookmark">LifeSouth in need of convalescent plasma, to host blood drives in Lanett and Valley</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
		<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-5'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-5'); });
  </script>
</div>		</div>
	</li>

  		
	<li id="custom_html-3" class="widget_text widget widget_custom_html"><h2 class="widgettitle">Calendar of Events</h2>
<div class="textwidget custom-html-widget">		<div id="calendarMask">
			<iframe src="https://calendar.google.com/calendar/embed?src=lagrangenews.com_s3ovjqk9760na8ak8e048n3mqc%40group.calendar.google.com&showTitle=0&showNav=0&showDate=0&showPrint=0&showTabs=0&showCalendars=0&showTz=0&mode=AGENDA&height=400&wkst=1&bgcolor=%23FFFFFF&color=%23A32929&ctz=America%2FNew_York" style=" border-width:0 " width="300" height="400" frameborder="0" scrolling="no"></iframe>		</div>
</div></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Opinion</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/our-view-fda-approval-should-mean-more-vaccinations/" title="Permalink to OUR VIEW: FDA approval should mean more vaccinations" rel="bookmark">OUR VIEW: FDA approval should mean more vaccinations</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/remembering-a-time-when-negative-was-positive/" title="Permalink to Remembering a time when  negative was positive" rel="bookmark">Remembering a time when  negative was positive</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/brooks-column-on-public-confession-of-sin/" title="Permalink to BROOKS COLUMN: On public confession of sin" rel="bookmark">BROOKS COLUMN: On public confession of sin</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/our-view-get-out-and-vote-in-special-election/" title="Permalink to OUR VIEW: Get out and vote in special election" rel="bookmark">OUR VIEW: Get out and vote in special election</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/thank-you-chambers-county/" title="Permalink to Thank you Chambers County" rel="bookmark">Thank you Chambers County</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-6'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-6'); });
  </script>
</div>		</div>
	</li>

	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Sports</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/baker-lafayette-run-all-over-coosa-central/" title="Permalink to Baker, LaFayette run all over Coosa Central" rel="bookmark">Baker, LaFayette run all over Coosa Central</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/valley-beats-lanett-in-another-classic-matchup-between-the-two-rivals/" title="Permalink to Valley beats Lanett in another classic matchup between the two rivals" rel="bookmark">Valley beats Lanett in another classic matchup between the two rivals</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/lanett-moves-to-no-1-in-class-2a-chambers-holds-at-no-5-in-latest-aswa-rankings/" title="Permalink to Lanett moves to No. 1 in Class 2A, Chambers holds at No. 5 in latest ASWA rankings" rel="bookmark">Lanett moves to No. 1 in Class 2A, Chambers holds at No. 5 in latest ASWA rankings</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/valley-native-scores-big-in-bass-fishing-tournament/" title="Permalink to Valley native scores big in bass fishing tournament" rel="bookmark">Valley native scores big in bass fishing tournament</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.valleytimes-news.com/2021/08/rising-from-the-ashes-lanett-cruises-to-win-100-for-coach-clifford-story/" title="Permalink to Rising from the ashes: Lanett cruises to win 100 for Coach Clifford Story" rel="bookmark">Rising from the ashes: Lanett cruises to win 100 for Coach Clifford Story</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  </ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/baker-lafayette-run-all-over-coosa-central/" rel="bookmark" title="Baker, LaFayette run all over Coosa Central">Baker, LaFayette run all over Coosa Central</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/valley-beats-lanett-in-another-classic-matchup-between-the-two-rivals/" rel="bookmark" title="Valley beats Lanett in another classic matchup between the two rivals">Valley beats Lanett in another classic matchup between the two rivals</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/charter-foundation-still-going-strong/" rel="bookmark" title="Charter Foundation still going strong">Charter Foundation still going strong</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/the-heritage-of-strength-woven-in/" rel="bookmark" title="The heritage of Strength Woven In">The heritage of Strength Woven In</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/lifesouth-in-need-of-convalescent-plasma-to-host-blood-drives-in-lanett-and-valley/" rel="bookmark" title="LifeSouth in need of convalescent plasma, to host blood drives in Lanett and Valley">LifeSouth in need of convalescent plasma, to host blood drives in Lanett and Valley</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/southern-film-festival-begins-in-lagrange-today/" rel="bookmark" title="Southern Film Festival begins in LaGrange today">Southern Film Festival begins in LaGrange today</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/chambers-county-school-district-going-all-virtual-next-week/" rel="bookmark" title="Chambers County School District going all-virtual next week">Chambers County School District going all-virtual next week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/estimated-1500-attend-concert-at-the-oaks-in-lafayette/" rel="bookmark" title="Estimated 1,500 attend concert at The Oaks in LaFayette">Estimated 1,500 attend concert at The Oaks in LaFayette</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/eamc-emergency-director-says-er-seeing-high-volumes/" rel="bookmark" title="EAMC Emergency Director says ER seeing high volumes">EAMC Emergency Director says ER seeing high volumes</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/west-point-home-severely-burnt-community-unites-to-help-resident/" rel="bookmark" title="West Point home severely burnt, community unites to help resident">West Point home severely burnt, community unites to help resident</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/glovis-georgia-building-new-facility-in-west-point-residents-voice-concerns/" rel="bookmark" title="Glovis Georgia building new facility in West Point, residents voice concerns">Glovis Georgia building new facility in West Point, residents voice concerns</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/bald-eagle-returned-to-wild-on-west-point-lake/" rel="bookmark" title="Bald eagle returned to wild on West Point Lake">Bald eagle returned to wild on West Point Lake</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/lanett-moves-to-no-1-in-class-2a-chambers-holds-at-no-5-in-latest-aswa-rankings/" rel="bookmark" title="Lanett moves to No. 1 in Class 2A, Chambers holds at No. 5 in latest ASWA rankings">Lanett moves to No. 1 in Class 2A, Chambers holds at No. 5 in latest ASWA rankings</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/chattahoochee-fuller-center-project-heads-to-pennsylvania/" rel="bookmark" title="Chattahoochee Fuller Center Project heads to Pennsylvania">Chattahoochee Fuller Center Project heads to Pennsylvania</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/four-candidates-qualified-for-west-point-city-council/" rel="bookmark" title="Four candidates qualified for West Point City Council">Four candidates qualified for West Point City Council</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/kia-georgia-reopens-direct-hiring-process-for-all-hourly-production-positions/" rel="bookmark" title="Kia Georgia reopens direct hiring process for all hourly production positions">Kia Georgia reopens direct hiring process for all hourly production positions</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/construction-on-camellia-crossing-underway/" rel="bookmark" title="Construction on Camellia Crossing underway">Construction on Camellia Crossing underway</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/mccoy-gives-update-on-streetscape-project/" rel="bookmark" title="McCoy gives update on streetscape project">McCoy gives update on streetscape project</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/chattahoochee-hospice-to-host-vaccine-forum/" rel="bookmark" title="Chattahoochee Hospice to host vaccine forum">Chattahoochee Hospice to host vaccine forum</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/new-guthries-in-lanett-nears-completion/" rel="bookmark" title="New Guthrie&#8217;s in Lanett nears completion">New Guthrie&#8217;s in Lanett nears completion</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/lanett-high-school-class-of-1970-presents-check-for-field-house-rebuild/" rel="bookmark" title="Lanett High School Class of 1970 presents check for field house rebuild">Lanett High School Class of 1970 presents check for field house rebuild</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/chambers-county-agricultural-arena-to-host-rodeo-barrel-horse-racing/" rel="bookmark" title="Chambers County Agricultural Arena to host rodeo, barrel horse racing">Chambers County Agricultural Arena to host rodeo, barrel horse racing</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/oak-bowery-vfd-chief-named-firefighter-of-the-year/" rel="bookmark" title="Oak Bowery VFD chief named firefighter of the year">Oak Bowery VFD chief named firefighter of the year</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://m.valleytimes-news.com/2021/08/valley-native-scores-big-in-bass-fishing-tournament/" rel="bookmark" title="Valley native scores big in bass fishing tournament">Valley native scores big in bass fishing tournament</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

						<div class="clearfix"></div>
					</div>
					<div id="footer" class="clearfix">

						<div id="footSections" class="col">
														<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://m.valleytimes-news.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://m.valleytimes-news.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://m.valleytimes-news.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
                <li><a href="https://marketplace.valleytimes-news.com/AdHunter/valleytimesnews/">Classifieds</a></li>
							</ol>
<!-- Mailchimp Newsletter Signup -->
<script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/unique-methods/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">window.dojoRequire(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us16.list-manage.com","uuid":"47ee7e89c9d398870f69b5758","lid":"2fb834aecb","uniqueMethods":true}) })</script>
								</div>

						</div>


						<div id="footServices" class="col">
														<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://m.valleytimes-news.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
																															</ol>
						</div>


						<div id="footCopyright" class="col">
							


							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2021, Valley Times-News</li>
							</ol>
						</div>

					</div>
				</div>

        <div id="mobile_footer_ad">
					<div class="ad">
						<!-- 320x50_mobile_sticky -->
<div id='div-gpt-ad-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-sticky'); });
  </script>
</div>					</div>
				</div>

				</div>

				<div class="sb-slidebar sb-left">
					<!-- Your left Slidebar content. -->
					<ul id="slidebarList">
					</ul>
				</div>


								<script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.js?1629743770"></script>
        <script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.timeago.js"></script>
				<script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/vendor/readmore.min.js"></script>
        <script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/plugins.js?1629743770"></script>
        <script src="https://www.valleytimes-news.com/wp-content/themes/2016-bni-mobile/media/js/main.js?1629743770"></script>

        <script>
  // disable text selection
  document.onselectstart=new Function ('return false');
</script>


<style>
  img {
    pointer-events: none;
    user-drag: none;
    -webkit-user-drag: none;
    -ms-user-drag: none;
    -moz-user-drag: none;
  }
</style>

<script type="text/javascript">
// Disable Right-click
var message="Right-click has been disabled";
function clickIE() {
    if (document.all) {
        (message);
        return false;
    }
}
function clickNS(e) {
    if (document.layers || (document.getElementById && !document.all)) {
        if (e.which == 2||e.which == 3) {
            (message);
            return false;
        }
    }
}
if (document.layers) {
    document.captureEvents(Event.MOUSEDOWN);
    document.onmousedown = clickNS;
} else {
    document.onmouseup = clickNS;
    document.oncontextmenu = clickIE;
}
document.oncontextmenu = new Function("return false");
</script>




	
				
<script type="text/javascript">tb_pathToImage = "https://m.valleytimes-news.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://m.valleytimes-news.com/wp-includes/js/thickbox/tb-close.png";</script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/m.valleytimes-news.com\/2021\/08\/southern-film-festival-begins-in-lagrange-today\/":29242};
	</script>
				<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/m.valleytimes-news.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://m.valleytimes-news.com/wp-includes/js/thickbox/thickbox.js?m=1629145607g'></script>
<script src='https://www.valleytimes-news.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://m.valleytimes-news.com/wp-includes/js/hoverintent-js.min.js?m=1629145607g'></script>
<script src='https://m.valleytimes-news.com/wp-includes/js/admin-bar.min.js?ver=5.8' id='admin-bar-js'></script>
<script id='admin-bar-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/m.valleytimes-news.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.valleytimes-news.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3' id='wp-polls-js'></script>
<script type='text/javascript' src='https://m.valleytimes-news.com/wp-includes/js/wp-embed.min.js?m=1629145607g'></script>
<script src='https://www.valleytimes-news.com/wp-content/mu-plugins/jetpack-10.0/_inc/build/postmessage.min.js?ver=10.0' id='postmessage-js'></script>
<script src='https://www.valleytimes-news.com/wp-content/mu-plugins/jetpack-10.0/_inc/build/jquery.jetpack-resize.min.js?ver=10.0' id='jetpack_resize-js'></script>
<script src='https://www.valleytimes-news.com/wp-content/mu-plugins/jetpack-10.0/_inc/build/likes/queuehandler.min.js?ver=10.0' id='jetpack_likes_queuehandler-js'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://www.valleytimes-news.com/wp-content/mu-plugins/jetpack-10.0/_inc/build/sharedaddy/sharing.min.js?ver=10.0' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202134#ver=202134' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script src='https://stats.wp.com/e-202134.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'176206029',post:'29242',tz:'-5',srv:'m.valleytimes-news.com'} ]);
	_stq.push([ 'clickTrackerInit', '176206029', '29242' ]);
</script>
				</div><!-- END undertone -->
        				<script id="dsq-count-scr" src="//valleytimes-news.disqus.com/count.js" async></script>
            </body>
</html>